Raspberry Pi 2 & 3 Prebuilt Image Evaluation Issue

I am attempting to evaluate the pantavisor prebuilt initial images. Have flashed images for raspberry pi2 and pi3 both not booting the OS. This is a really basic issue but im wondering if there is something im missing with the img flashing process to help the initial image boot.

My attempt is to evaluate viability of the pantavisor ecosystem for embedded hardware deployment and i may end up posting other questions as i go.

We always recommend to follow our get started guide using a rpi3 b+ or rpi4. If you could get a hand on one of these, it would be great.

Also, maybe take a look at our troubleshooting page:

Hi, thank you for the response.
so here are my findings:

I downloaded the following images from pantahub and flashed with 0 success:
RPI4, RPI3 and RPI2, used two different sets of sd cards to make sure that it wasnt hardware compatibility etc issue.
**** arm-rpi2/3/4.img.gz archives from pantahub ****
Realized that i was seeing the same issue across all devices (no boot, blank screen). for sanity tested just rasbian no gui on the same sd card and one of the rpi (rpi3-b) which worked just fine.

So, i went ahead downloaded the “rpi3_initial_stable.img.xz” from (https://pantavisor-ci.s3.amazonaws.com/pv-initial-devices/tags/016/348823585/rpi3_initial_stable.img.xz) using the same method which i had tried on all rpi2/3/4 version (raspberry imager, also i use dd a lot which didnt work either in earlier attempts).

This image booted off just fine and now am at the pantavisor console. Very excited and wanted to post my findings. I am certain there must be some issue with my method when flashing these images earlier however also wanted to report so you guys could do verification on your end as well.

I will be starting new threads for questions i have from here on forward.

1 Like

Hi, the main images we support for both rpi3 and rpi4 are actually our unified 64-bit images. For that you need to choose one of the “arm-rpi64” variants in the download wizard.

Also, I can confirm that the 32-bit images are currently broken when downloaded from the wizard. We fix this in next release. Thanks for reporting.